sonar-qube Test

Description

Checks whether a component has an associated SonarQube project

Notes

Priority

High
2 passing tests
54 not applicable tests

56 Test Results

Component Test Teams Priority Outcome Message
sonar-qube Kronicle App High passing

Component has these SonarQube project(s):

sonar-qube Kronicle Service High passing

Component has these SonarQube project(s):

sonar-qube /restapis/h8lrgxlzia High not applicable

Component type aws-apigateway-restapi is not expected to have a SonarQube project

sonar-qube /restapis/h8lrgxlzia/stages/prod High not applicable

Component type aws-apigateway-restapi-stage is not expected to have a SonarQube project

sonar-qube Amazon AWS High not applicable

Component type third-party-platform is not expected to have a SonarQube project

sonar-qube apilambdacruddynamodbexa-itemscanaryartifactsbuck-18c7zoqkjweyy High not applicable

Component type aws-s3-bucket is not expected to have a SonarQube project

sonar-qube apilambdacruddynamodbexa-itemscanaryartifactsbuck-d195wkjsj079 High not applicable

Component type aws-s3-bucket is not expected to have a SonarQube project

sonar-qube apilambdacruddynamodbexa-itemscanaryartifactsbuck-wexqqs83o0i6 High not applicable

Component type aws-s3-bucket is not expected to have a SonarQube project

sonar-qube ApiLambdaCrudDynamoDBExample/exampleVpc/publicSubnet1 High not applicable

Component type aws-ec2-subnet is not expected to have a SonarQube project

sonar-qube ApiLambdaCrudDynamoDBExample/exampleVpc/publicSubnet2 High not applicable

Component type aws-ec2-subnet is not expected to have a SonarQube project

sonar-qube Bitbucket Server High not applicable

Component type third-party-platform is not expected to have a SonarQube project

sonar-qube cdk-hnb659fds-assets-621347945510-us-west-2 High not applicable

Component type aws-s3-bucket is not expected to have a SonarQube project

sonar-qube cluster/kronicle High not applicable

Component type aws-ecs-cluster is not expected to have a SonarQube project

sonar-qube Datadog High not applicable

Component type third-party-platform is not expected to have a SonarQube project

sonar-qube default High not applicable

Component type aws-ec2-route-table is not expected to have a SonarQube project

sonar-qube example High not applicable

Component type aws-ec2-vpc is not expected to have a SonarQube project

sonar-qube GitHub High not applicable

Component type third-party-platform is not expected to have a SonarQube project

sonar-qube GitLab High not applicable

Component type third-party-platform is not expected to have a SonarQube project

sonar-qube kronicle High not applicable

Component type aws-ec2-vpc is not expected to have a SonarQube project

sonar-qube kronicle High not applicable

Component type aws-ec2-internet-gateway is not expected to have a SonarQube project

sonar-qube Kronicle CDK Config
  • kronicle-project

    The Kroncile Project maintains this AWS CDK config for Kronicle

High not applicable

Component type aws-cdk-config is not expected to have a SonarQube project

sonar-qube Kronicle Helm Chart High not applicable

Component type helm-chart is not expected to have a SonarQube project

sonar-qube kronicle-mBQhLU High not applicable

Component type aws-secretsmanager-secret is not expected to have a SonarQube project

sonar-qube KronicleStack-KronicleTaskDefinitionKronicleAppLogGroup7917096D-hbJWmCaNIKYO High not applicable

Component type aws-logs-log-group is not expected to have a SonarQube project

sonar-qube KronicleStack-KronicleTaskDefinitionKronicleServiceLogGroupC47F3164-3LExDck3krwn High not applicable

Component type aws-logs-log-group is not expected to have a SonarQube project

sonar-qube KronicleStack/KronicleVpc/publicSubnet1 High not applicable

Component type aws-ec2-subnet is not expected to have a SonarQube project

sonar-qube KronicleStack/KronicleVpc/publicSubnet1 High not applicable

Component type aws-ec2-route-table is not expected to have a SonarQube project

sonar-qube KronicleStack/KronicleVpc/publicSubnet2 High not applicable

Component type aws-ec2-subnet is not expected to have a SonarQube project

sonar-qube KronicleStack/KronicleVpc/publicSubnet2 High not applicable

Component type aws-ec2-route-table is not expected to have a SonarQube project

sonar-qube Lambda Example High not applicable

Component type microservice is not expected to have a SonarQube project

sonar-qube lambda-example-canary High not applicable

Component type aws-synthetics-canary is not expected to have a SonarQube project

sonar-qube lambda-example-create-item-function High not applicable

Component type aws-lambda-function is not expected to have a SonarQube project

sonar-qube lambda-example-delete-all-items-function High not applicable

Component type aws-lambda-function is not expected to have a SonarQube project

sonar-qube lambda-example-delete-item-function High not applicable

Component type aws-lambda-function is not expected to have a SonarQube project

sonar-qube lambda-example-get-all-items-function High not applicable

Component type aws-lambda-function is not expected to have a SonarQube project

sonar-qube lambda-example-get-item-function High not applicable

Component type aws-lambda-function is not expected to have a SonarQube project

sonar-qube lambda-example-update-item-function High not applicable

Component type aws-lambda-function is not expected to have a SonarQube project

sonar-qube lambda-example-vpc High not applicable

Component type aws-ec2-vpc is not expected to have a SonarQube project

sonar-qube lambda-example-vpc High not applicable

Component type aws-ec2-security-group is not expected to have a SonarQube project

sonar-qube lambda-example-vpc High not applicable

Component type aws-ec2-internet-gateway is not expected to have a SonarQube project

sonar-qube lambdaexample-canaryartifactsbucket4a60d32b-1ge3uxzkslhlr High not applicable

Component type aws-s3-bucket is not expected to have a SonarQube project

sonar-qube LambdaExample/Vpc/publicSubnet1 High not applicable

Component type aws-ec2-route-table is not expected to have a SonarQube project

sonar-qube LambdaExample/Vpc/publicSubnet1 High not applicable

Component type aws-ec2-subnet is not expected to have a SonarQube project

sonar-qube LambdaExample/Vpc/publicSubnet2 High not applicable

Component type aws-ec2-subnet is not expected to have a SonarQube project

sonar-qube LambdaExample/Vpc/publicSubnet2 High not applicable

Component type aws-ec2-route-table is not expected to have a SonarQube project

sonar-qube parameter/cdk-bootstrap/hnb659fds/version High not applicable

Component type aws-ssm-parameter is not expected to have a SonarQube project

sonar-qube security-group/sg-02cce8a30060083f0 High not applicable

Component type aws-ec2-security-group is not expected to have a SonarQube project

sonar-qube security-group/sg-04c41ee3f4784c3d5 High not applicable

Component type aws-ec2-security-group is not expected to have a SonarQube project

sonar-qube security-group/sg-0883304a22bc5c867 High not applicable

Component type aws-ec2-security-group is not expected to have a SonarQube project

sonar-qube security-group/sg-08d171ce301f089a7 High not applicable

Component type aws-ec2-security-group is not expected to have a SonarQube project

sonar-qube security-group/sg-0f3679355b8367345 High not applicable

Component type aws-ec2-security-group is not expected to have a SonarQube project

sonar-qube SonarQube High not applicable

Component type third-party-platform is not expected to have a SonarQube project

sonar-qube stack/ApiLambdaCrudDynamoDBExample/8ed56130-a17f-11ec-9987-069883ee9c53 High not applicable

Component type aws-cloudformation-stack is not expected to have a SonarQube project

sonar-qube stack/LambdaExample/a4af8de0-bb02-11ec-a648-06d50a8e10b9 High not applicable

Component type aws-cloudformation-stack is not expected to have a SonarQube project

sonar-qube table/lambda-example-dynamodb-table High not applicable

Component type aws-dynamodb-table is not expected to have a SonarQube project

sonar-qube Zipkin High not applicable

Component type third-party-platform is not expected to have a SonarQube project

Kronicle App v0.1.260